Ubuntu 8.10 mit HP Compaq 6715s

Nachdem ich hier schonmal kurz beschrieben habe, wie ich 7.10 auf dem Rechner zum Laufen gebracht habe, folgt jetzt das Update auf 8.10:

  • Zunächst das Update via Update-Manager und stabiler Internetverbindung auf 8.04 (LTS). Hier hab es keine Probleme, ich wollte das System ja auch gar nicht nutzen, sondern nur den Zwischenschritt machen. Nachdem ich in den Paketquellen entschieden habe, nicht nur über LTS-Updates informiert zu werden, erschien auch der Hinweis, dass es bereits eine 8.10 gibt 😉
  • Ebenfalls problemloses Upgrade auf 8.10.
  • Nach dem Neustart aber zunächst leider kein Bild, bzw. nach dem sog. Splash-Screen verschand der Screen völlig. Erst ein händisches noapic in den Boot-Optionen machte das „durchbooten“ möglich.
  • WLAN ging nun leider auch nicht mehr. Ein Blick mit dmesg brachte zu Tage: installier b43-fwcutter (aptitude install b43-fwcutter). Nun lief das WLAN auch wieder 😉
  • Der Boot-Vorgang dauerte ewig. Nach langem Suchen bin ich dann auf diesen Eintrag gestoßen und habe im Boot-Menü den Eintrag „nohz=off“ ergänzt.

Alles läuft prima 😉

Tags: , ,

7 Antworten auf “Ubuntu 8.10 mit HP Compaq 6715s”

  1. Tester sagt:

    WLAN funktioniert bei mir nach einem Update auf 9.10 nicht out of the box – es bricht alle Paar Sekunden die Verbindung ab. Modul das geladen wird ist hier wl. Schon in der Version 8.10 funktionierten Befehle iwlist und iwconfig seltsammerweise gar nicht. Verbindung _und_ Verschlüsselung mit WPA2 liefen jedoch bestens, deshalb hat es mich nicht gekümmert. Mit dem NetworkManager war ich nicht glücklich und habe wicd installiert. Und noch etwas: die Schnittstelle trägt den Namen eth1 und nicht wie meistens wlan*. Nun, werde ich den b43-fwcutter ausprobieren – Vielen Dank für die Infos.

  2. Tester sagt:

    Es geht um ein update auf 9.04 und nicht auf 9.10! 🙂

  3. blafasel sagt:

    Mein Update auf 9.04 steht noch bevor… kannst ja mal vermelden, ob b43-fwcutter mit 9.04 auch den gewünschten Erfolg gebracht hat 😉

    • Tester sagt:

      jep – das war es!:) WLAN mit WPA2 läuft ohne Unterbrechung.

      Mit dem Modul wl habe ich von wicd immer Messages bekommen, dass ich mit meinem Netwerk verbunden bin, jedoch „bei 0%“. Die Verbindung wurde immer wieder abgebrochen. Nachdem die Firmware/b43-fwcutter drauf war, habe ich nur mittels ’sudo rmmod wl‘ – das wl entladen und mit ’sudo modprobe b43′ – b43 geladen. Über tail -f /var/log/messages konnte ich sofort sehen, dass das Interface nun wieder den Namen wlan* trägt: udev: renamed network interface wlan0 to wlan1. (habe wahrscheinlich noch wlan0 in irgendeiner *.config mit der ich gespielt habe und deshalb das Unbenennen in wlan1?). wicd meldet jetzt Verbindung bei unterschiedlich vielen Prozent und die Verbindung wird nicht unterbrochen – so wie es „damals in den Zeiten“ von Feisty Fawn (noch mit ndiswrapper?) war. Darüber hinaus gibt es jetzt noch ein Interface wmaster0… iwconfig sagt zum wmaster0: „no wireless extensions“. JA, iwconfig und ‚iwlist scanning‘ funktionieren jetzt auch wieder! 🙂 Habe denoch alle Interfaces außer eth0 aus /etc/udev/rules.d/70-persistent-net.rules gelöscht – werde mir anschauen, was udev nach dem reboot dort einträgt. Habe zusätzlich zum automatischen Laden b43 in /etc/modules eingetragen und wl zum Verhinderung seines Ladens in /etc/modprobe.d/blacklist.conf eingetragen. Dabei sah ich, dass es eine /etc/modprobe.d/blacklist-bcm43.conf gibt, wo b43 blackgelistet war – habe den Eintrag gelöscht.

      Die /etc/network/interfaces enthält keine Einträge außer zur lo-Interface – so verlangt es wicd und ich gehe davon aus, dass es sich nach dem reboot auch mit dem Unbenennen von wlan0 zum wlan1 klären wird. Falls es gleich etwas aufregendes geben sollte, dann werde ich berichten.

      • Tester sagt:

        Es funkt mit der Firmware und den Einstellungen auch nach dem Neustart wie gewollt – bestens. Das Interface wmaster0 ist immer noch da. Habe auch eine Erklärung:

        „The master device wmaster0

        mac80211 creates creates one master device and as many other secondary devices as requested to represent interfaces for the wireless card you have. mac80211 asks for the master device to appear as named as wmaster%d, and wlan%0 for the interfaces. udev may override the naming convention used though. wmaster%d is an internal master device used only by mac80211. It is currently visible only because it uses netdevice structure which we must allocate and use for for QoS. It also serves as a holder for all interfaces we have, and represent the underlying hardware. For example, when TXing your wlan0 STA interface will actually add IEEE-802.11 header data to a frame with just Ethernet headers, and then pass it down to the master device for actual transmission using the low level drivers.The wlan%d devices (interfaces) are the devices you would use to configure your wireless settings. “
        http://www.linuxwireless.org/en/developers/Documentation/mac80211

        Alles andere lief schon – Ubuntu 9.04 auf Compaq 6715s.
        Im menu.lst habe ich ’noapic‘ gelöscht – es geht auch mit ’noacpitimer‘. ’nohz=off‘ ist leider auch notwendig.

        • blafasel sagt:

          Danke für Deine Hinweise – dann sehe ich meinem Update ja gelassen entgegen :-)!

        • Martin sagt:

          Sag mal – kam bei Dir keine Warnmeldung, dass die Grafikkarte nicht mehr unterstützt wird? Ich habe mein Upgrade daraufhin abgebrochen…

Kommentiere

*